home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 03-13-2020, 09:18 PM   #1
vovo240740
Newbie
 
Join Date: Sep 2019
Exclamation LH 2.2 (1988 245): Jumping the pump causes sparks

Hello all, this is my first post on this website, sorry if a thread already exists but I can't find a similar one.

After troubleshooting why my 88 wagon won't start, I narrowed it down to the fuel system. I have spark and compression and it even starts on starter fluid. The issue I'm having is the main 25a fuse that is located next to my coil keeps on blowing when trying to start her.

I tried to jump the fuel pump but im unable to because it sparks and shocks me, I actually got 3rd degree burn on my fingers when i tried this. Yes I am jumping the proper fuse ( 4 to 6) and it worked for a few days but now it's impossible to because of the clear problem that happening.

My main question is, why can't I jump my pump anymore and do i need to get new pumps, or is there an electrical gremlin in my fule system that is causing my pumps to fail or not even get activated.

I replaced my fuel relay and didn't help.

how to I test my fuel pumps to see if they work?

thanks for the help fellow reblock enthusiasts

vovo240740 is offline   Reply With Quote
Old 03-13-2020, 11:51 PM   #2
Dirty Rick
Board Member
 
Dirty Rick's Avatar
 
Join Date: Apr 2013
Location: Cornholio, OR
Default

You could measure the current the pump is drawing.
Or unplug the pump in the back and see if it still blows the fuse.

If it blows the fuse when you plug the pump back in that would indicate your pump has stained it's sheets.
Pull it and test it?

Be sure check or replace any fuel filters
__________________
I don't know who I am when I am somebody else.

Last edited by Dirty Rick; 03-13-2020 at 11:57 PM..
Dirty Rick is offline   Reply With Quote
Old 03-13-2020, 11:58 PM   #3
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

Sounds like you have a short in the wiring or the pump.
__________________
No Start Thread
ZVOLV is offline   Reply With Quote
Old 03-14-2020, 01:47 AM   #4
Otto Mattik
Chief Bottle Washer
 
Otto Mattik's Avatar
 
Join Date: Dec 2015
Location: Upper Midwest..more or less
Default

Quote:
Originally Posted by vovo240740 View Post
I tried to jump the fuel pump but im unable to because it sparks and shocks me, I actually got 3rd degree burn on my fingers when i tried this.

It's highly doubtful you have a 3rd degree burn from jumping the fuel pump.
1st degree burn(3rd degree burn goes thru the skin to the muscles and/or bones) ?

Also careful creating large arcs around any possible fuel leaks.
__________________
Desperate need of elf assistant for interior work - Cash/Beer option $


Feedback thread: http://forums.turbobricks.com/showthread.php?t=323689

Last edited by Otto Mattik; 03-15-2020 at 04:00 AM..
Otto Mattik is offline   Reply With Quote
Old 03-14-2020, 07:50 AM   #5
cleanflametrap
Board Member
 
cleanflametrap's Avatar
 
Join Date: Sep 2009
Location: near baltimore
Default

Was the 25A fuse blowing before you began to troubleshoot the no-start?
__________________
-Art
cleanflametrap is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:30 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.