home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 06-23-2020, 03:50 PM   #1
Bready
board deviant
 
Bready's Avatar
 
Join Date: Nov 2002
Default Intermittent Performance issue

2001 C70 5 speed manual having an intermittent issue and was looking for some direction.

Normally car runs fine, but about 25% of the time after starting I run into the following:

1) Really noticeable "drag" when coming off the gas while in gear. Usually I can come off the gas and it's normal smooth sailing, when the issue is occurring there is a big almost "throw you forward" scenario when you take your foot off the gas
2) When occurring, when I hit 4K RPM it goes into what I would describe as "limp mode" - right at the 4K line, go back under that and it runs relatively normally

I can typically turn the car off and restart it (maybe once or twice) and it goes back to normal.

Thoughts?
__________________
Quote:
Originally Posted by Pennybridge Pioneer View Post
Just because you didn't experience something growing up doesn't mean other people didn't. Case in point: I can't remember ever being a total moron, but that doesn't mean you aren't one.
Quote:
A society that treats this much Black death at the hands of the state as collateral damage in a just war on crime has no decorum to project. That society is savage. - Charles M. Blow
Kalazdar - (3/23/83 to 5/12/03)
MUST READ!!! https://cleantechnica.com/2017/04/24...-adds-screwed/
Bready is online now   Reply With Quote
Old 06-23-2020, 04:06 PM   #2
MistrThou
Masked Moogle
 
MistrThou's Avatar
 
Join Date: Oct 2004
Location: Janesville, WI
Default

Maybe a waste gate hanging up? Any codes or lights? Maybe a soft code without the light? I'd think anything timing or sensor related would throw a code. Perhaps weak fuel pressure?
__________________
Quote:
Originally Posted by Old Guru
Current cars: Something old, something new, something borrowed, something Maroon.
MistrThou is offline   Reply With Quote
Old 06-24-2020, 11:48 AM   #3
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

I wanna guess air leaks.
__________________
No Start Thread
ZVOLV is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:48 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.