home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 11-27-2019, 01:26 PM   #26
R-Pow3R3d
Master of Disaster
 
R-Pow3R3d's Avatar
 
Join Date: Sep 2018
Location: Pittsburgh, PA
Default

Quote:
Originally Posted by lummert View Post
Brake hoses deteriorate internally resulting in a one way check valve type effect.
Yeah, replaced those with stainless.
__________________
1990 745 Turbo Intercooler
2007 XC90 V8 Sport
2007 XC70
R-Pow3R3d
R-Pow3R3d is offline   Reply With Quote
Old 12-23-2019, 12:27 AM   #27
R-Pow3R3d
Master of Disaster
 
R-Pow3R3d's Avatar
 
Join Date: Sep 2018
Location: Pittsburgh, PA
Default

Quote:
Originally Posted by R-Pow3R3d View Post
That sounds very similar to mine. If this issue shows back up after this, the 4 wheels in the air test will be next. A brake upgrade could be in the works if I can't sort anything out else.
I've really hesitated to report back without knocking on a lot of wood, but it seems as though the master cylinder replacement has solved my problem. I've been able to put a couple hundred miles on without recurrence. Fingers crossed this is the last of this issue.

Of course, shortly after getting this solved, my ODO quit working (AGAIN!). I've seen DNA Speedometers mentioned a couple times here. I may reach out to them and give them a shot to rebuild it.
R-Pow3R3d is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:02 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.